On Fri, 2 Mar 2007, Samantha wrote:

On Thursday 01 March 2007 01:18:03 pm Rustom Mody wrote:
> I need to use ruby 1.8.5 whereas the linux I am using -- ubuntu edgy --
> gives 1.8.4.
>
> Tried to download sources and compile.
>
> Seemed to go fine but when I tried to setup gem it barfed saying the
> zlib library is not available
>
> Also the up-arrow key is not working in irb
>
> So any pointers to compiling ruby on ubuntu-edgy?

I don't know about Ubuntu, but Debian has 1.8.5 in unstable. In Debian the 
procedure to build an "unstable" version on stable would be:

# vim /etc/apt/sources.list
# # add a source line for unstable sources
# apt-get install build-dep ruby1.8
# apt-get source ruby1.8
# cd ruby1.8*
# debuild

*t

--
-----------------------------------------------------------
   Tomas Pospisek
   http://sourcepole.com -  Linux & Open Source Solutions
-----------------------------------------------------------