On Fri, 02 Mar 2007 03:18:03 +0900, Rustom Mody wrote:

> I need to use ruby 1.8.5 whereas the linux I am using -- ubuntu edgy --
> gives 1.8.4.
> 
> Tried to download sources and compile.
> 
> Seemed to go fine but when I tried to setup gem it barfed saying the
> zlib library is not available
> 
> Also the up-arrow key is not working in irb
> 
> So any pointers to compiling ruby on ubuntu-edgy?

First off, you can install ruby on Ubuntu by running "apt-get install 
ruby". If you can't do that because you're trying to compile some more 
recent version of ruby, then you can pull in Ruby's build dependancies by 
running "apt-get build-dep ruby1.8" which should install everything you 
need to compile Ruby. (Also be sure to install build-essential if you 
haven't already done so -- I think you have otherwise you wouldn't have 
made it this far.)

--Ken

-- 
Ken Bloom. PhD candidate. Linguistic Cognition Laboratory.
Department of Computer Science. Illinois Institute of Technology.
http://www.iit.edu/~kbloom1/