A while back there was a proposal to use a standard naming scheme for 
meta-programming methods. It went like this:

   object_id
   object_class (instead of class)
   object_send (instead of send)
   object_method (instead of method)

Then for all the methods that bypass access restrictions:

   instance_send (instead of funcall)
   instance_eval
   instance_exec
   instance_variable_get
   instance_variable_set
   instance_variables

The discussion didn't go much farther then but I'd like to reignite the 
bikeshed. Personally I think it's a brilliant idea; sure the method 
names are longer but that seems perfectly acceptable to me since 
meta-programming should not be used that often. The naming is consistent 
and obvious, it avoids ugliness like __send__, it reduces chances of 
naming conflict (CgiRequest#method, Email#send), it allows a simple 
pattern match to recognize any meta-programming methods, and it's 
already half implemented. Are there any other people who support this idea?

Daniel