On Feb 27, 2007, at 05:39, Damian Terentyev wrote:
> I have problems installing and running RubyGems with Ruby 1.9.
> Most of all they arise because of File.exists? method was changed  
> to File.exist?, but there may be other inconsistencies as well.

Do you have a patch?  Please file it in the RubyGems bug tracker.   
(If you post it here, I'm sure it will get lost.)

> Has anyone successfully installed RubyGems for 1.9?

Not recently, no.  1.9 is too much of a moving target to say any  
particular piece of software is guaranteed to work with it.

> Maybe it is possible  to get RubyGems from subversion repository?

Unlikely.  I don't believe any such changes have been made.

> I also have another question maybe anyone knows what was the  
> purpose of changing the name of the aforementioned method, because  
> at first sight it seems to contradict Ruby english-like syntax and  
> the Principle of Least Surprise.

It was deprecated in 1.8.