Good day all!
I have problems installing and running RubyGems with Ruby 1.9.
Most of all they arise because of File.exists? method was changed to 
File.exist?, but there may be other inconsistencies as well.
Has anyone successfully installed RubyGems for 1.9?
Maybe it is possible  to get RubyGems from subversion repository?

I also have another question  maybe anyone knows what was the purpose 
of changing the name of the aforementioned method, because at first 
sight it seems to contradict Ruby english-like syntax and the Principle 
of Least Surprise.

Yours sincerely,
Damian/Three-eyed Fish