On Mon, 2007-02-19 at 18:14 +0900, Robert Dober wrote:
> Hi all
> 
> I was just following the thread about "loop cannot count down" and
> was about to propose a monkey patched method which might have been
> convenient for the poster.
> 
> Like e.g. Range#each_down  (bad name I know).
> 
> The point is, I cannot, because Range#each is based on succ, and
> Range#each_down would be based on pred.
> 
> I just wonder if it might not be a good idea to define pred for all
> core classes for which succ is defined. I kind of feel stupid not
> having suggested that in the first place, now :(.
> (http://rcrchive.net/rcrs/6)
> 
> Opinions?

It seems you beat me to it :)

I'm sure it's been brought up before, and it will surely add more
complexity to a problem that seems relatively small, based on the low
volume of posts on it here on the mailing list.


Cheers,
Daniel