Sometimes #pred is harder than #succ, e.g. singly linked list.

But yes, I agree.

Didn't we have some "step x" syntax?

Googling found it:

http://www.ruby-doc.org/core/classes/Numeric.html#M000139

Aur

On 2/19/07, Robert Dober <robert.dober / gmail.com> wrote:
> Hi all
>
> I was just following the thread about "loop cannot count down" and
> was about to propose a monkey patched method which might have been
> convenient for the poster.
>
> Like e.g. Range#each_down  (bad name I know).
>
> The point is, I cannot, because Range#each is based on succ, and
> Range#each_down would be based on pred.
>
> I just wonder if it might not be a good idea to define pred for all
> core classes for which succ is defined. I kind of feel stupid not
> having suggested that in the first place, now :(.
> (http://rcrchive.net/rcrs/6)
>
> Opinions?
>
> Cheers
> Robert
>
> --
> We have not succeeded in answering all of our questions.
> In fact, in some ways, we are more confused than ever.
> But we feel we are confused on a higher level and about more important things.
> -Anonymous
>
>