On Feb 14, 2007, at 8:45 AM, Kalman Noel wrote:
> This makes me think that a Ruby programmer should maybe use the  
> word allォ
> in several cases where you would use unォ or サstartォ or サprocessォ in
> other languages. Provided that allォ makes some sense in a  
> specific case,
> it will line up beautifully with the core library. lias [] callォ may
> come in handy, too.

It might also make sense to define #to_proc as in:

class Extra
   def initialize(i)
     @i = i
   end
   def call(a)
     a + @i
   end
   def to_proc
     lambda {|a| call(a) }
   end
end

add5 = Extra.new(5)

[1,2,3,4].map &add5     # [6,7,8,9]


Gary Wright