Markus Liebelt schrieb:
> Hello all together,
> 
> today I upgrade from Ruby 1.82 to 1.85-21, I installed it under windows 
> with the one-click-installer. Most of my previous work works without a 
> change, but I cannot get Tk working.

Tk is not part of the one-click-installer any more. See change note:

2006-02
* Updated release notes to mention that the install now
   only contains bindings to Tcl/Tk and that to use Tcl/Tk
   you must install it (recommending ActiveTcl).

Wolfgang NŠŇasi-Donner