Hello all together,

today I upgrade from Ruby 1.82 to 1.85-21, I installed it under windows  
with the one-click-installer. Most of my previous work works without a  
change, but I cannot get Tk working. Let me explain what is happening:

1. For 1.82, I installed ActiveTcl (Version 8332), and copied some of the  
libraries to ruby.
2. I tried that as well in the new ruby installation, but when I want to  
use Tk, ruby feezes, and I don't get any feedback (no error, nothing).
3. I removed the copied libraries, and tried just to use Tk in IRB.
   - Start IRB, then "require 'tk'"

==> D:\programme\tcl\ActiveTcl8332>irb
irb(main):001:0> require 'tk'

    Then ruby is frozen, and I have to kill the process.

What am I missing here? Is Tk in the one-click-installer not included  
(seems so). What are the prerequisits for ruby to use tk widgets in ruby?  
Is it necessary to have the tcl/tk binaries in the path under windows?

It would be nice if you had any idea how to locate the error. At the  
moment, I don't have a clue.

Bye
	Markus