I'm trying to install ruby on an older linux box. When I install, with
./configure, make, ..., it errors out on make with an error in the
openssl version (needs 9.7 and i have 9.6). I installed a new openssl in
a different location (/usr/local/ssl/bin/openssl) and kept the old one
in place.

I configure via:
./configure --with-openssl=/usr/local/ssl/bin/openssl

and when I run make it errors out in same place with:

"gcc -I../.. -I../../. -I../.././ext/openssl  -g -O2   -c conftest.c"
conftest.c:3:3: #error "OpenSSL version is less than 0.9.7."
checked program was:
/* begin */
1: #include <openssl/opensslv.h>
2: #if OPENSSL_VERSION_NUMBER < 0x00907000L
3: # error "OpenSSL version is less than 0.9.7."
4: #endif
/* end */

Is there any way I can see whether the new openssl install is being
used?

-j

-- 
Posted via http://www.ruby-forum.com/.