Thank you all for your comments!
>
> Change "fase" to "phase".
Doh. Changed.
>
> Also, I think there is a typo in the opening. Where you say
> "Ruby is slow", I think what you mean is "Ruby is an extremely
> powerful and flexible language". It's an understandable mistake,
> all of the keys are so close to each other. ;)
I fixed that, that always happens to me, my keyboard must have been low 
on batteries
>
> Thanks for the section and examples on Ruby mark-and-sweep, this
> is something I've been having some trouble with.
Your welcome :)
> You recommend using the "rb_" prefix on classes, modules, etc., but 
> I'd argue that rb_-prefixed names should be reserved for things 
> defined by Ruby itself, and your extension should use some other 
> naming convention.
You're right, I've changed that now.
> You use names_array->ptr[i] to access elements in an array. My choice 
> would be to use rb_ary_index instead, to put a little logical distance 
> between my code and the RArray structure definition. You could use 
> rb_ary_length to get the array size as well.
Hmmm I never even heard of that, would probably be better. I'll look 
into it after my exams, and if I like it, I'll change it.
> Regarding "Where to go from here," another good learning resource is 
> the C sources for the builtin classes. I frequently refer to string.c, 
> array.c, io.c, etc. to see how things should be done.
You're right, I added that.
> One item on my wishlist would be to show (in perhaps a sidebar) how to
> use mkrf instead of mkmf. 

I haven't heard of mkrf yet, but I'll also check that out after my 
exams. Thanks for the suggestion.

Wim