On Sun, 2007-01-21 at 08:43 +0900, Jonathan Allen wrote:
> matt wrote:
> > On Sun, 2007-01-21 at 03:32 +0900, Ab Cd wrote:
> >> Whenever I start FreeRIDE I get a ton of warnings. It takes a long
> >> time
> >> to start as well, probably because it is I/O bound to the console
> >> window.
> >> 
> >> Suggestions?
> > 
> > Yes 2 of them:
> > 1) Don't post the thousands of repeated errors to the list
> > 2) Ask the fx ruby folks what the problem is.
> 
> They say its Ruby's fault for putting the bug in v1.8.5 and FreeRide's 
> fault for not upgrading to FX Ruby v1.6. Though I suppose they share 
> part of the blame for not making backwards compatible.
> 
> Now what?
> 
> Jonathan
> 

1. Fix the bug in ruby and submit patch
2. fix FreeRides dependency to use a newer version of FXRuby
or
3. Find another IDE.  

try VI or [X]Emacs or pico or notepad or word or works or OpenOffice
or... 

ohh you want an all in one... try Eclipse or RadRails  I've never used
either of them, but they (among others) have gotten good reviews.

Matt