On Mon, 8 Jan 2007, Trans wrote:

> Think I need a better name for this method. It is anything but
> dangerous. Any ideas?
>
>  # As with #store but adds the key/value pair
>  # only if the key isn't already in the hash.
>
>  def store!(key, value)
>    unless key?(key)
>      store(key,value)
>      return value
>    end
>  end

store_once ?


Kirk Haines