On Fri, 5 Jan 2007 dblack / wobblini.net wrote:


>
> Ah ha, my OO-er than thou claim comes back to haunt me! :-)  I actually
> don't usually talk in terms of more/less OO, and I know I'm guilty of
> introducing that into this discussion... but I will say that I don't think
> "one object responsible" is a principle of OO.  It may be that the ability
> to override send is a problem, but obj.send("message") is, I think, a pretty
> object-oriented way to go about things.
>

heh.  i think we're all in agreement then.  something should be done so
encapsulate the notion of 'this must always work' for a certain group of
methods.  i'm for a module/syntax based solution or, at the very least, a
consistent naming convention.  if you're reading matz, what do you think?

is anyone feeling up to summarizing and making a RCR?

-a
-- 
in the practice of tolerance, one's enemy is the best teacher.
- the dalai lama