I've recently moved a Rails app from a Linux box to a Solaris container.
The app makes use the excellent sparklines plug-in which in turn depends
on RMagick. The Solaris box has RMagick gem 1.1.3 compiled against
GraphicsMagick 1.1.7 (same as the Linux box).

Unfortunately the sparklines plug-in makes use of methods on
Magick::Draw that are present on the Linux box, but not on the Solaris
box and I'm rather confused as to why this would be the case. Here's a
list of the missing methods:

"fill", "opacity", "rectangle", "scale", "line", "define_clip_path",
"stroke_antialias", "pop", "gravity", "fill_rule", "text_align",
"ellipse", "stroke_dasharray", "font", "stroke_dashoffset", "matte",
"clip_path", "font_family", "text_anchor", "point", "stroke_linecap",
"pointsize", "clip_rule", "skewx", "font_stretch", "bezier",
"text_antialias", "text", "encoding", "stroke_linejoin", "font_size",
"path", "clip_units", "skewy", "text_undercolor", "rotate",
"fill_color", "stroke_miterlimit", "arc", "polygon", "color", "stroke",
"affine", "extend_with_included_modules_from", "font_style", "pattern",
"circle", "fill_pattern", "stroke_opacity", "polyline", "decorate",
"stroke_color", "font_weight", "roundrectangle", "enable_warnings",
"fill_opacity", "translate", "stroke_width", "stroke_pattern", "push"

Does anyone have an idea what might be going on? Thanks in advance for
any help.

Rob

-- 
Posted via http://www.ruby-forum.com/.