On 1/1/07, Trans <transfire / gmail.com> wrote:

> Looking at Phrogz' wiki page of names I came up with:
>
>   customize do
>     ...
>   end
>
> Then the class could be called the 'customization'. Ie. the above being
> equvalent to:
>
>   customization.class_eval do
>     ...
>   end

That sure looks pretty.  I do think maybe it'd be confusing to
remember where the code in the block to customize() is actually being
evaluated, but this could be a decent alternative.

Then again, I don't have any beef at all with singleton class/method
OR eigen class/method

I'd just like to see an end to (class << self; self; end) and
preferably avoid seeing 'meta' become part of method names, lest we
begin the meta_meta  and  the meta_meta_meta ;)