Hi,

In message "Re: Little Things"
    on Mon, 1 Jan 2007 05:42:23 +0900, Devin Mullins <twifkak / comcast.net> writes:

|I take it you don't like meta_class, the most often proposed name for 
|it. How about virtual_class, or singleton_class, or both?

It's not really a meta class since it's not only for classes,
nor virtual_class since it's not virtual anymore.

In my mindset, two candidates have survived.  singleton_class (or
singletonclass), which can easily be confused with a class in the
singleton design pattern.  And eigenclass, which is unfamiliar for
most people.

							matz.