Pe No wrote:
> when using :
> require 'net/https' under jRuby 0.92
> i get the following error :
> 
> /Users/yvon/bin/jruby/lib/ruby/1.8/openssl/cipher.rb:57:in `new' wrong
> argument.
> 
> 
> this is using the script given by "jin" at
> <www.jinsync.com/files/jinsync_0.25_alpha.zip>
> 
> but most probably has nothing to do with jin's script rather than jRuby
> environment.

Interesting. Can you pop over to the JRuby dev or user lists and report 
this again? The SSL support in JRuby is extremely new, so you may have 
stumbled on a problem with it.

-- 
Charles Oliver Nutter, JRuby Core Developer
Blogging on Ruby and Java @ headius.blogspot.com
Help spec out Ruby today! @ www.headius.com/rubyspec
headius / headius.com -- charles.nutter / sun.com