I have a stock gentoo ruby/rails install.  I get something like this
when I
try to use script/generate, rake migrate or script/console and probably
others.

0 wicked www/sharkwatch % ./script/console
Loading development environment.

/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/core_ext/hash/keys.rb:27:in
`symbolize_keys':NoMethodError: undefined method `to_sym' for
#<YAML::Syck::MergeKey:0xb71dfa6c>

to_sym is indeed *not* defined in /usr/lib/ruby/1.8/yaml.rb or
/usr/lib/ruby/1.8/yaml/*

What's going on here?

Thanks,
--Dean