Hi,
  I am trying to install ruby-shout(used to serve audio to icecast
server) .I have libshout,vorbis and liboggz
But I get this error

ERROR:  While executing gem ... (RuntimeError)
    ERROR: Failed to build gem native extension.
Gem files will remain installed in
/usr/lib/ruby/gems/1.8/gems/ruby-shout-2.1 fo
r inspection.


Results logged to
/usr/lib/ruby/gems/1.8/gems/ruby-shout-2.1/ext/gem_make.out

I am not sure what the "failed to build native extension " means.
Any ideas
vivek