On Dec 13, 2006, at 13:14, Jeff Watson wrote:

> Hello, I am running Zenlinux 4.0 and i cannot seem to get Ruby Gems  
> to work
> correctly. Zen ships with 1.8.4.. i tried to install gems 0.9
>
> sudo ruby setup.rb
>
> gives me an error
>
> "LoadError: no such file to load"
>
> the file is obviously there... ( ls says so:-D )
>
> so i removed the 1.8.4 and installed 1.8.5 to see if that was the  
> problem,
> same result. My end goal is to get RoR running, and it seems  
> crippled at
> this juncture. Any idea why i would not be able to install gems? it  
> seems to
> get the same LoadError: kind of error whenever i try and "require"  
> ANYTHING.
> going insane!

Please post the full error from "ruby setup.rb"

You're probably missing the sources gem.

This has probably been fixed in rubygems svn.

-- 
Eric Hodel - drbrain / segment7.net - http://blog.segment7.net

I LIT YOUR GEM ON FIRE!