On Sun, 21 Oct 2001, Mathieu Bouchard wrote:

> On Mon, 22 Oct 2001, Robert Feldt wrote:
> 
> > 1, Replace functionality of existing "caller", ie. keep the current name.
> > 2, New name "call_stack"
> > 3, New name "execution_stack"
> > 4, New name "stack_frames" (? la Wayne's new patch (but note that I 
> >    haven't checked it out yet; maybe different semantics, better or
> >    whatever...)
> > 
> > More proposals?
> 
> 
> Please see
> 	RCR #29
> 	More Reflection - Sat, Aug 25
> 	http://www.rubygarden.org/article.php?sid=89
> 
Yes, this is a better approach than previous proposals and IMHO the
"right" way to do it.

Maybe we should an argument to Binding#caller that will traverse the
bindings until 0 (either returning them all or just the "last" one). But,
of course, its trivial with the current proposal.

If its accepted Kernel.caller should probably be deprecated...

And we should probably delete (my) RCR #15 since it is superseded by #29. 

Regards,

Robert