On Mon, 22 Oct 2001, Wayne Conrad wrote:

> On Sun, 21 October 2001, Yukihiro Matsumoto wrote:
> > check out [ruby-talk:12097] and [ruby-talk:12111] by Robert Feldt.
> 
> Doumo!
> 
BTW matz, any plans on including this in the 1.7 series? I still find it
very useful but I'm styaing away from using it since I want my extensions
to work with all Ruby interpreters not only mine...

If the naming is still the issue (and naming is important!) then maybe we
can collect some proposals and take a vote?

1, Replace functionality of existing "caller", ie. keep the current name.
2, New name "call_stack"
3, New name "execution_stack"
4, New name "stack_frames" (? la Wayne's new patch (but note that I 
   haven't checked it out yet; maybe different semantics, better or
   whatever...)

More proposals?

Regards,

Robert Feldt