Can anyone explain why I'm suddenly getting the following errors?
The large program that reports them (an editor) was working fine before
I updated my gentoo system.   Get these at startup.   Everything seems
to be working fine otherwize....

/usr/lib64/ruby/site_ruby/1.8/glib2.rb: line 44
   GLib-GObject-CRITICAL **:g_boxed_type_register_static: assertion
`g_type_from_name (name) == 0' failed
/usr/lib64/ruby/site_ruby/1.8/glib2.rb: line 44
   GLib-GObject-CRITICAL **:g_param_spec_boxed: assertion
`G_TYPE_IS_BOXED (boxed_type)' failed
/usr/lib64/ruby/site_ruby/1.8/glib2.rb: line 44
   GLib-GObject-CRITICAL **:g_object_class_install_property: assertion
`G_IS_PARAM_SPEC (pspec)' failed
/usr/lib64/ruby/site_ruby/1.8/glib2.rb: line 44
   GLib-GObject-CRITICAL **:g_param_spec_boxed: assertion
`G_TYPE_IS_BOXED (boxed_type)' failed
/usr/lib64/ruby/site_ruby/1.8/glib2.rb: line 44
   GLib-GObject-CRITICAL **:g_object_class_install_property: assertion
`G_IS_PARAM_SPEC (pspec)' failed
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb: line 21
   GLib-GObject-WARNING **:IA__g_object_notify: object class
`GtkTextBuffer' has no property named `copy-target-list'


Thanks,

Bill