On 12/10/06, richard.j.dale / gmail.com <richard.j.dale / gmail.com> wrote:
> It's because you're picking up the Qt3 version of QtRuby which doesn't
> have that constructor. If you install the Qt3 version after the Qt4
> version the default when you do a require 'Qt' will be the Qt3 one. If
> you install the Qt4 version of QtRuby after the Qt3 one, then the
> default is Qt4 instead. Maybe use require 'Qt3' or require 'Qt4' to
> make sure you get the right one.

Thanks! requiring 'Qt4' fixed it. How do I make Qt go back to defaulting to Qt4?

martin