Bart Braem wrote:

> Hello,
> 
> Does anyone know good Ruby 3D Math libraries? I found Math3D
> (<http://raa.ruby-lang.org/project/math3d/>) but I can not get it working,
> ruby extconf.rb fails:
> $ ruby -r mkmf extconf.rb
> checking for atan() in -lm... no
> No atan() in -lm

For some reason, you have a very limited math library on your system.
Chances are you will succeed in the compilation if you will replace your
math library with a complete one.

It is a little difficult to believe there is a math library without
"atan()", and it implies there is something basically wrong with the one
installed on your system.

My point is that the Math3D library is not the problem, it is solely a
problem with your native-code math library, on which Math3D depends.

-- 
Paul Lutus
http://www.arachnoid.com