Has anyone been able to build Ruby on MacOS 10.1? I was able to build
it before on MacOS 10, but now, on 10.1, when I run configure, I get
this:

[localhost:~/Documents/Downloads/ruby-1.6.5] kelpie% ./configure
creating cache ./config.cache
checking host system type... powerpc-apple-darwin1.4
checking target system type... powerpc-apple-darwin1.4
checking build system type... powerpc-apple-darwin1.4
checking for gcc... no
checking for cc... cc
checking whether the C compiler (cc  ) works... no
configure: error: installation or configuration problem: C compiler
cannot create executables.


config.log ends up looking like this:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:601: checking host system type
configure:622: checking target system type
configure:640: checking build system type
configure:777: checking for gcc
configure:807: checking for cc
configure:890: checking whether the C compiler (cc  ) works
configure:906: cc -o conftest    conftest.c  1>&5
/usr/bin/ld: /usr/lib/libSystem.dylib load command 6 unknown cmd field
configure: failed program was:

#line 901 "configure"
#include "confdefs.h"

main(){return(0);}


Which really doesn't help me.


If anybody has any ideas, I'd really appreciate it.

Thanks in advance,
Will Conant