Hello --

On Sun, 21 Oct 2001, Mark Hahn wrote:

>
> It bothers me also.  How about this for a solution:
>
> 	x.each with {|i| doit}
>
> 	x.each with
> 	{
> 		|i|
> 		doit
> 	}
>
> The "with" keyword could be optional, just like the "then" keyword.

I'd rather see backslashes :-)  Besides,

   x.each with do |i| ... end

looks pretty awful.

It's hard for me to say beyond that because I think having the method
name and the block params on the same line looks better and is
clearer.  Also, it looks weird to me to have anything between a method
name and a block (except for arguments to the method).


David

-- 
David Alan Black
home: dblack / candle.superlink.net
work: blackdav / shu.edu
Web:  http://pirate.shu.edu/~blackdav