On 12/6/06, Robert Klemme <shortcutter / googlemail.com> wrote:
>
> Hm.  I am not convinced this is a good idea at all.  Usually the
> recommendation is that methods should do one thing - and one thing only.
>   Combining map with join seems like a clear violation of that principle
> as map and join do extremely different things.

See my reply to Logan - my argument is that often (particularly when
converting data structures to a textual representation) map-then-join
*is* what you want to be doing, and if you're doing a nested series of
them, it's ugly to scatter joins in between the map blocks.

> Having said that I'd prefer a more efficient implementation:

Definitely - I just posted the code to explain what I wanted the
method to do. Note that an added advantage is that you needn't create
the temporary array for the map step.

martin