Hi,
I am porting Ruby/SDL to SkyOS (which has Ruby 1.8.5 installed) and I can compile it fine, no errors or warnings, but when I try to execute "require 'sdl'" it bums out with 

/path/to/sdl.so: "Unable to load global library - /path/to/sdl.so" (LoadError)
	from /path/to/sdl.rb: 17 (which is require 'sdl.so')

I have never seen this error before and searching on Google turns up no results, any insight would be great.

Thanks
-- 
Steven Davidovitz