Absolutely... I'm not a linux expert though, but I have a feeling
they're installing somewhere that ruby can't see them.  What can I do
to ensure apt-get is behaving properly?


See below:

[/root] # apt-get install openssl
Reading package lists... Done
Building dependency tree
Reading state information... Done
openssl is already the newest version.

[/root] # apt-get install libssl-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libssl-dev is already the newest version.


Thank you,
Chad




On Dec 2, 4:46 am, Jose francisco Gonzalez carmona
<pgonza... / naupacto.com> wrote:
> do you have 'openssl' installed? try to install, libssl0.9.8 or highet
> and libssl-dev.
>
> jflez.
>


>
>
> Chad wrote:
> > Help!
>
> > Why do I continually get the following error?
>
> > ------------------------------------------------------------
> > irb(main):001:0> require 'openssl'
> > LoadError: no such file to load -- openssl
> >         from (irb):1:in `require'
> >         from (irb):1
> > ------------------------------------------------------------
>
> > I've tried everything in every post about this.  I've blown away my
> > ruby install like 6 times.  How do I get ruby to recognize openssl?
>
> > I've installed:
>
> > ubuntu
> > ruby 1.8.5
> > libopenssl-ruby
> > libzlib-ruby
> > libyaml-ruby
> > libdrb-ruby
> > liberb-ruby
> > zlib1g-dev
>
> > Any suggestions?
> 
> > Thank you,
> > Chad--
> Posted viahttp://www.ruby-forum.com/.