The following still has the same problem:

open("http://www.google.com", "User-Agent" => "Mozilla/4.0")

-- 
Posted via http://www.ruby-forum.com/.