Laurent a ˝─rit :
> Hello,
> 
> I'm currently trying to make run a Rails webapp over Oracle XE (Express
> Edition 10g)
> 
> I started to :
> Install Ruby 1.8.5 (One Click Installer) for Windows
> Install Rails 1.1.6
> Install ruby-oci8 (Windows ruby script)
> 
> Then i setup the database.yml in my web app as the following:
> 
> development:
> adapter: oci
> host: localhost/xe
> username: rails_dev
> password: secret
> 
> While generating a model : script/generate model product
> I get the error:
> 
> C:\ruby\lib\ruby\gems\1.8/gems/activerecord-1.14.4/lib/active_record/conne
> ction_adapters/abstract/connection_specification.rb:194:in
> `establish_connection
> ': development database is not configured
> (ActiveRecord::AdapterNotSpecified)
> from C:\ruby\lib\ruby\gems\1.8/gems/activerecord-1.14.4/lib/active
> _record/connection_adapters/abstract/connection_specification.rb:185:in
> `establi
> sh_connection'
> 
> Has anyone already seen this kind of error...
> I have several Oracle Homes on my system, but i've set before the
> ORACLE_HOME pointing to the Oracle XE database home.
> 
> Any idea?
> 
> Laurent
> 
Hello Laurent,
There is a short tutorial on Oracle Technology Network:
<http://www.oracle.com/technology/pub/articles/haefel-oracle-ruby.html>
It might help.
Jean-Pierre