"Mike Woodhouse" <mikewoodhouse / gmail.com> wrote in message 
news:1164188725.362280.73130 / h54g2000cwb.googlegroups.com...
>
>
> On Nov 22, 9:27 am, "Just Another Victim of the Ambient Morality"
> <ihates... / hotmail.com> wrote:
>>     I tried to install the new mechanize gem package but it failed saying 
>> I
>> needed Hpricot.  So, I'm trying to find a gem package for that but it
>> doesn't appear to exist.  The Hpricot website says that I can get it from
>> RubyForge but RubyForge doesn't have it so now I'm lost and no amount of
>> googling is helping me.
>>     Can anyone point me to where I can find the latest Hpricot gem?
>>     Thank you...
>
> _why's installation instructions are here:
> http://code.whytheluckystiff.net/hpricot/wiki/InstallingHpricot

    If you look at the very page you list, here, you'll see that it says 
that you can get the gem package at RubyForge.  As far as I can tell, this 
is a damn dirty lie.


> or go straight for
>
> gem install hpricot --source code.whytheluckystiff.net

    I could try this.  I'm just curious why the gem isn't freely 
distributed... or why some people think it is freely distributed...
    Thanks...