[code]
#!/usr/bin/ruby1.8
require 'yaml'
a = { "b" => "c", "d" => nil, "e" => "f" }
puts a.to_yaml
[/code]

result:

---
b: c
d:
e: f

but must be:

---
b: c
d: ~
e: f

-- 
Posted via http://www.ruby-forum.com/.