Hi,

has anyone had any success getting ruby-prof working on amd64 linux? 
Specifically, has anyone managed to deal with this error, or know what 
it is referring to:

/home/dan/ruby$ ruby-prof prime.rb
/usr/local/lib/ruby/gems/1.8/gems/ruby-prof-0.4.1/bin/ruby-prof:154:in 
`load': integer 23456248293192 too big to convert to `int' (RangeError)
        from 
/usr/local/lib/ruby/gems/1.8/gems/ruby-prof-0.4.1/bin/ruby-prof:154
        from /usr/local/bin/ruby-prof:18

(this happens with any ruby script)

There are a couple of people who have mentioned it on the rubyforge 
project page but without any apparent resolutions, other than that 
nothing on google.

thanks,
Dan

for ref:
/home/dan/ruby$ uname -a
Linux x1-6-00 2.6.15-27-amd64-generic #1 SMP PREEMPT Sat Sep 16 01:50:50 
UTC 2006 x86_64 GNU/Linux
/home/dan/ruby$ ruby -v
ruby 1.8.4 (2005-12-24) [x86_64-linux]

-- 
Posted via http://www.ruby-forum.com/.