tk>  ruby don't search the file tk.h, it try to preprocess (with cpp) this
file
tk>
tk> pigeon% cat conftest.c
tk> #include <tk.h>
tk> pigeon%

Ok, I installed everything with these rpm:s.
tcl.rpm
tcl-devel.rpm
tk.rpm

tk>  This mean that you must have on your system, all include files needed
by
tk>  tk.h. For example you need X11/Xlib.h

Do I have to build both tcl and tk from source? I tried that the first time,
but it didn't go very well.