On 10/13/06, Brian Mitchell <binary42 / gmail.com> wrote:
> On 10/13/06, Brian Mitchell <binary42 / gmail.com> wrote:
> > On 10/13/06, Tim Bray <tbray / textuality.com> wrote:
> > > unpack doesn't seem to take a block.  This seems like an obvious
> > > thing to want if I'm going to work with a big input string and not
> > > burn memory.  Am I missing something? -Tim
> >
> > Possibly a good idea. Lets go ahead and try it out.
> >
> > class String
> >   def unpack_each(format)
>
>  On second thought... each_unapck is a much better name.

Shouldn't it just be 'unpack', and have some 'if block_given?' juice
squeezed on it?