Drew,

"Drew Olson" <olsonas / gmail.com> wrote on 10/5/06 7:30 pm:
> I've become a die-hard Ruby fan in the past few months. I'm currently
> using 1.8.5 on my work PC and want to upgrade on my mac at home, which
> is currently running 1.8.2. It seems the neither Fink nor Darwinports
> has 1.8.5 available so I'd like to install from source, but I've never
> done this before.
> 
> Can anyone offer help (like step by step) to a total newbie when it
> comes to installing from source?

I followed the instructions at Hivelogic[1]. I ran into one problem, but
solved that in the comments at my blog[2]. Other URLs that may help or point
to common errors are included afterwards [3, 4]

1: 
<http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger>
2: 
<http://nslog.com/archives/2006/10/04/building_ruby_rails_lighttpd_and_mysql
_on_tiger.php>

3: 
<http://www.nabble.com/Ruby-1.8.4-Mac-OS-X-readline-problems-t801880.html>
4: <http://www.ruby-forum.com/topic/83481>


-- 
     Best wishes,
     Erik J. Barzeski

1 + 1 = 3; // for large values of 1
------------------------------------------------------
AIM: iacas    BLOG: nslog.com    GOLF: thesandtrap.com
------------------------------------------------------