Well i have also problems using gentoo,suse or slackware gems fox/fxruby 
(i even had the same error messages  so it´s the same problem i 
guess...). Well my problem was sort of solved, after installing 
fox/fxruby from the source and not from the gem.

right now i use fox and fxruby 1.6.1 and it all works nicely.


Mark Chandler schrieb:

>Lyle Johnson wrote:
>  
>
>>On 10/1/06, Mark Chandler <mark / chandlerm.com> wrote:
>>
>>    
>>
>>>irb(main):002:0> require_gem 'fxruby'
>>>NameError: uninitialized constant Fox
>>>        from (irb):3
>>>      
>>>
>>What do you get if you do:
>>
>>    require 'rubygems'
>>
>>followed by:
>>
>>    require 'fox14'
>>
>>-- Lyle
>>    
>>
>
>LoadError: no such file to load -- fox14
>        from 
>/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in 
>`gem_original_require'
>        from 
>/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
>        from (irb):2
>
>  
>