I have the same problem with digest.so not existing, but with Ruby
1.8.4 on Mandrake 10.1. I've tried Googling for digest.so, but I'm only
coming up with Perl modules.