> require 'open-uri'
> require'watir'
> require 'fileutils'
> require 'net/http'

Madu,

The error you have is coming out of Watir which unfortunately I have no 
experience with.

For the code sample you posted, you only need to include open-uri.

watir, fileutils and net/http are unused by your code sample.

As Jean proposed, I suggest you debug your application by breaking it in 
smaller pieces.

Stephane

-- 
Posted via http://www.ruby-forum.com/.