They probably just didn't update that page since 1.8.5 recently came  
out.  I'm running 1.8.5 with Rails 1.1.6 fine.

On Sep 16, 2006, at 1:22 PM, Collin Miller wrote:

> On 9/16/06, Victor Reyes <victor.reyes / gmail.com> wrote:
>>
>> Hello Forum,
>> I would like to play and learn Rails with Ruby
>> I heard of the so called Ruby on Rails.
>> I recently purchased two ruby/rail books: Rails Recipes (Pragmatic
>> Programmers) and Ruby for Rails: Ruby Techniques for Rails  
>> Developers.
>>
>> I installed Ruby 1.8.5 under Windows/XP and under AIX 5.3.  
>> However, I now
>> would like to installed Rails.
>> The problem is that I am not sure if the current version of Rails
>> (whatever
>> that is) is compatible with Ruby 1.8.5.
>> Can anyone tell me the best approach to combine Ruby and Rails  
>> together?
>> Is there a one-click installer of both?
>>
>> Thank you
>
>
>
> From RubyonRails.org:
>
> We recommend Ruby 1.8.4 for use with Rails. Ruby 1.8.2 is fine too,  
> but
> version 1.8.3 is not.
>
> Should probably stick with1.8.4 for now.
>
> Install RubyGems http://docs.rubygems.org/ --> download and run " ruby
> setup.rb "
>
> Then run " gem install rails "
>
> This will give you the latest build. " gem update rails " will  
> update to the
> latest build
>
> This should get you set up.