On Wed, 13 Sep 2006, Richard Conroy wrote:

> What are their release dates? Have all of the library/ plugin and
> existing code problems been addressed? How Rails compatible
> are they? Has the rush to be version compatible with various
> libraries introduced any exploits? Can I patch my customers
> installations right now?
>
> Basically "How soon can I hot swap my interpreter in my rails
> app with No ill effects".

You can't.  You won't be able to.  Fortunately, Ruby encompasses a much 
larger world than Rails.  The Ruby that YARV runs is different from your 
1.8.4 or 1.8.5 ruby version, and Rails will have to change to accomodate 
it, not the other way around.


Kirk Haines