On Sep 8, 2006, at 3:10 PM, andre in LA wrote:

> which ruby yelds
> /usr/local/bin/ruby
>
> the version of ruby is 1.8.4
>
> Thank you in advance

Don't thank me for much. If I recall correctly, if you just type  
'gem' on the command line you get some kind of error message instead  
of a helpful explanation of usage. The thing is that I have exactly  
the same setup as you and it just works. Well I'm using ruby 1.8.5  
now but it did work when I was on 1.8.4. I installed SWIG to get  
Instiki to work but to the best of my recollection gem was working  
for me before I did that. You might give it a try. You don't have  
anything to loose at this point.   <http://www.swig.org/>
Maybe someone more knowledgeable than I will chime in.
--
The folly of mistaking a paradox for a discovery, a metaphor for a  
proof, a torrent of verbiage for a spring of capital truths, and  
oneself for an oracle, is inborn in us.
-Paul Valery, poet and philosopher (1871-1945)