Paul Lutus wrote:

> What version of Ruby do you have? I ran the same test and didn't get this
> message. And what platform? Mine:
> 
> $ ruby -v
> ruby 1.8.4 (2005-12-24) [i386-linux]

% ruby -v
ruby 1.8.5 (2006-08-25) [powerpc-darwin8.7.0]
(that is, MacOS X 10.4.7)