On 1/9/2006, at 19:37, khaines-at-enigo.com wrote:

> [...] It looked like this:
>
> if pu : pu = pu.url.to_s != '' ? pu : nil end
>
> [...] Sure, it's concise [...]

    > concise: giving a lot of information clearly
    > and in a few words; brief but comprehensive

Seeing how it assigns pu to pu (in one case) I would classify that  
part as redundant :)

Here?s my 20% more concise version:

     pu = nil if pu && pu.url.to_s.empty?