On 01/09/06, khaines / enigo.com <khaines / enigo.com> wrote:
> if pu : pu = pu.url.to_s != '' ? pu : nil end
> ...
> Sure, it's concise, but what did I gain by making it so concise over
> making it so that it was clearly readable a year and a half later?
> ...
> Sometimes clever is good, when there is a reason for it.  However, that
> time, clever was just plain stupid.

Perhaps it's just not clever enough! ;-) It's concise, but it could be
more concise and maybe a little clearer at the same time:

pu = nil if pu && pu.url.to_s.empty?

... although I think I'd be more inclined to write it out using the
multi-line if form.

Paul.