can anyone provide a good reason why both of these should not work?

   harp:~ > ruby -r rubygems -e'  require_gem "dynaload", "~> 0.1";  p Dynaload::VERSION  '
   "0.2.0"


   harp:~ > ruby -r rubygems -e'  require_gem "dynaload", "~> 0.1.0";  p Dynaload::VERSION  '
   /home/ahoward//lib/ruby/site_ruby/1.8/rubygems.rb:204:in `report_activate_error': RubyGem version error: dynaload(0.2.0 not ~> 0.1.0) (Gem::LoadError)
           from /home/ahoward//lib/ruby/site_ruby/1.8/rubygems.rb:141:in `activate'
           from /home/ahoward//lib/ruby/site_ruby/1.8/rubygems.rb:37:in `require_gem_with_options'
           from /home/ahoward//lib/ruby/site_ruby/1.8/rubygems.rb:31:in `require_gem'
           from -e:1


in addition, the error is most misleading...  i'm unclear why it wouldn't simply do

   version = version.split(%r/\./).first(2).join('.')

to ignore the trailing digit.

i guess i'm thinking that this is a bug.

-a
-- 
to foster inner awareness, introspection, and reasoning is more efficient than
meditation and prayer.
- h.h. the 14th dali lama